This project is read-only.

"New thread" link missing?

Aug 31, 2011 at 10:18 AM

Hi, I am trying this modul in orchard (where I am new x))

I have one problem. In admin I see create new forum, list of forums, but there is no link for creating new thread - not in admin, not in frontend (in forntend I have only "Threads, There are no threads for this forum." and no link what is in screenshots on web :((( )

What should I do? Install process was ok, no error, so... I don't know what is wrong :( I installed this from gallery in orchard. Is possible that something is missing on server? some role or function in iis?


Thanks to everyone

Aug 31, 2011 at 1:34 PM

Hey Gollumek,

You are right that there is no 'New Thread' button in the backend.. this may change, though in my perspective why have two ways of creating threads right?

There should be a 'Create Post' link when you drill down in to a forum right?

If that link is still not displayed check to see if the Forum is marked as 'Is Closed' - To do this just edit the forum and make sure it is unchecked.

Let me know how it goes.


Aug 31, 2011 at 3:49 PM

Hi Jetski5822,

I don't see "New Thread" in frontend too :( When I open forum in frontend I can see only Threads - there are no threads for this forum if I am logged or not. Forum is not closed (this checkbox is unchecked, I tried all what module "offer" to me)... Is possible that I have to add some Content Part into Thread or forum? Because I can't see this link nowhere.... :(

Screen 1 - what I see in admin (only one created forum, button for adding new forum and some selectlist.
Screen 2 - when I open created forum, that is all what I can see in backend (i understand, that when I will have new threads then I find them on this place)
Screen 3 - this is what I see from frontend when I am logged (or not, the view is same :( ), only this no link to create new thread like some user logged or not
and Screen 4 - this opens when I click on Edit link in frontend (when I am logged in) - there is only forum properties/description and some other...

I think that is some my mistake, but I have no idea where I could this mistake made... I've insalled this from gallery in admin, everything for forum is enabled....


Thanks :)

Aug 31, 2011 at 3:55 PM
Edited Aug 31, 2011 at 3:56 PM

Hmmm Odd!!... Okay, the theme you are using, is this your theme? Are you allowing the 'Meta' section?

As that lives within the meta section.. Parts_Forums_Forum_Manage="Meta:2"

Aug 31, 2011 at 5:32 PM

Theme is made from "The time machine" I tried to preserve all tag. Meta section there is, that I am sure. Here is _Layout.cshtml (if it helps) it is adapted theme, because I work with Orchard for first time :) So I need to learn more and more and with mvc3 it is similar... :)

and a Parts_Forums_Forum_Manage="Meta:2" is genereated into <head><meta ..... /></head> in _Layout? Don't understand it much :(




Aug 31, 2011 at 6:01 PM

hmm Any chance you could Zip up your theme and email it to me? Jetski5822 at gmail dot com

Ill take a look at it for ya :)

Aug 31, 2011 at 6:52 PM

I sent it to you :)

Sep 4, 2011 at 11:48 AM

Hey did you manage to debug this in the end?

Sep 7, 2011 at 9:04 PM

I had the same problem when I used a Bing theme. I changed to the Contoso theme and it was resolved.